partner
Norbert Longawa
1 134 pkt
12 pytań
576 odpowiedzi
3 pomysłów
86 komentarzy
394 98%
oceń

Brak połączenia z bazą danych SQL - brak dostępu do serwera

Norbert Longawa zapytał/a o
Techniczne
Techniczne pytań: 1497 | odpowiedzi: 5675

Jerzy ZiajaKinga KotelnickaMagdalena GrygaMonika KalaDominik WajdaPiotr PrzybyszOlga WitosMarcin Łach
Comarch ERP Optima
Comarch ERP Optima pytań: 4835 | odpowiedzi: 19305

Optima

Jerzy ZiajaKinga KotelnickaJózef ĆwiąkałaKarolina SypułaMariusz SzczebakMagdalena Grygabartek rosińskiMarzanna Sapkowska

Cześć,

jestem w kropce. Na jednej końcówce od rana otrzymuję błąd połączenia z bazą danych (w załączeniu). Krótki opis sytuacji:

  • instalacja nie jest świeża,
  • nie było upgrade'u Optimy,
  • nie było aktualizacji windy,
  • próba połączenia po nazwie / po adresie IP nie robi różnicy,
  • został ustawiony alias w cliconfg,
  • serwer się pinguje,
  • serwer jest dostępny z poziomu końcówki (dostęp do plików),
  • asysta proponuje to co jest dostępne w Pomocy i to co zostało zrobione zanim zapytałem.

Ktoś, coś ? Zasadniczo jedyna zmiana jaka nastąpiła to wyłączenie serwera, dołożenie RAM, odpalenie serwera. Na innych końcówkach problemu nie ma - to jest jedyny komputer z problemem.

PS. Optima była już odinstalowana i zainstalowana ponownie.

Odpowiedzi:

User Avatar
partner
Jacek Kamiński
1 516 pkt
7 pytań
474 odpowiedzi
9 pomysłów
96 komentarzy
436 95%
oceń
 
Jacek Kamiński odpowiedział/a
Techniczne
Techniczne pytań: 1497 | odpowiedzi: 5675

Jerzy ZiajaKinga KotelnickaMagdalena GrygaMonika KalaDominik WajdaPiotr PrzybyszOlga WitosMarcin Łach
Comarch ERP Optima
Comarch ERP Optima pytań: 4835 | odpowiedzi: 19305

Optima

Jerzy ZiajaKinga KotelnickaJózef ĆwiąkałaKarolina SypułaMariusz SzczebakMagdalena Grygabartek rosińskiMarzanna Sapkowska
11 mie. temu

Witam, czy podałeś w Optimie po przecinku port jaki jest ustawiony w "czerwonej" teczce (na którym nasłuchuje SQL)? Może masz ustawione na dynamiczny port, który nie jest znajdowany przez Optimę ? Może masz na ustawiony inny port na IP x dla IP który pingujesz ? 

Ps. z czystej ciekawości chętnie bym to zobaczył przez TV.

User Avatar
partner
Rafał Cebulski
6 957 pkt
3 pytań
1801 odpowiedzi
10 pomysłów
58 komentarzy
1172 98%
oceń
 
Rafał Cebulski odpowiedział/a
Techniczne
Techniczne pytań: 1497 | odpowiedzi: 5675

Jerzy ZiajaKinga KotelnickaMagdalena GrygaMonika KalaDominik WajdaPiotr PrzybyszOlga WitosMarcin Łach
Comarch ERP Optima
Comarch ERP Optima pytań: 4835 | odpowiedzi: 19305

Optima

Jerzy ZiajaKinga KotelnickaJózef ĆwiąkałaKarolina SypułaMariusz SzczebakMagdalena Grygabartek rosińskiMarzanna Sapkowska
11 mie. temu

Sprawdź czy jak ustawiłeś alias w cliconfig to poprawnie się zapisał w kluczu w rejestrze na końcówce:

\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\Client\ConnectTo

User Avatar
partner
Stanisław Pachacz
3 238 pkt
12 pytań
273 odpowiedzi
67 pomysłów
108 komentarzy
710 98%
2 pkt
 
Stanisław Pachacz odpowiedział/a
Techniczne
Techniczne pytań: 1497 | odpowiedzi: 5675

Jerzy ZiajaKinga KotelnickaMagdalena GrygaMonika KalaDominik WajdaPiotr PrzybyszOlga WitosMarcin Łach
Comarch ERP Optima
Comarch ERP Optima pytań: 4835 | odpowiedzi: 19305

Optima

Jerzy ZiajaKinga KotelnickaJózef ĆwiąkałaKarolina SypułaMariusz SzczebakMagdalena Grygabartek rosińskiMarzanna Sapkowska
11 mie. temu

Powiem Ci że podobne zachowanie systemu mam jak na laptopie mam aktywne drugie poza WiFi, połączenie komórkowe.

Baza SQL jest lokalna na tym laptopie, MSSMS normalnie się podłącza, ale Optima już nie.

User Avatar
partner
Norbert Longawa
1 134 pkt
12 pytań
576 odpowiedzi
3 pomysłów
86 komentarzy
394 98%
oceń
 
Norbert Longawa odpowiedział/a
Techniczne
Techniczne pytań: 1497 | odpowiedzi: 5675

Jerzy ZiajaKinga KotelnickaMagdalena GrygaMonika KalaDominik WajdaPiotr PrzybyszOlga WitosMarcin Łach
Comarch ERP Optima
Comarch ERP Optima pytań: 4835 | odpowiedzi: 19305

Optima

Jerzy ZiajaKinga KotelnickaJózef ĆwiąkałaKarolina SypułaMariusz SzczebakMagdalena Grygabartek rosińskiMarzanna Sapkowska
11 mie. temu
Emil - ustawienia sieci były bez zmian a innych instancji nie było (trzeba by utworzyć) / Łukasz - serwer ma 2 karty ale używana 1, zmiana nazwy końcówki nic nie dała / Jacek - port nie był dynamiczny tylko wskazany od początku na poprawny 🙂 / Rafał - było OK / Staszek - przy próbie wyłączenia wszystkiego łącznie z Bluetooth i połączeniach tylko przy 1 aktywnym połączeniu - bez zmian. Pomogło dopiero przywrócenie ustawień domyślnych z poziomu Win10 - działa...
Ta odpowiedź została skomentowana
User Avatar
partner
Daniel Trzeciak
24 pkt
5 pytań
10 odpowiedzi
1 pomysłów
1 komentarzy
4 100%
oceń
 
Daniel Trzeciak odpowiedział/a
Techniczne
Techniczne pytań: 1497 | odpowiedzi: 5675

Jerzy ZiajaKinga KotelnickaMagdalena GrygaMonika KalaDominik WajdaPiotr PrzybyszOlga WitosMarcin Łach
Comarch ERP Optima
Comarch ERP Optima pytań: 4835 | odpowiedzi: 19305

Optima

Jerzy ZiajaKinga KotelnickaJózef ĆwiąkałaKarolina SypułaMariusz SzczebakMagdalena Grygabartek rosińskiMarzanna Sapkowska
11 mie. temu

Też tak miałem ostatnio, tez sam komunikat. Sprawdziłem wszystko (pingi, firewalle, aliasy, adresację, management, porty, hosts) a jedna ze stacji roboczych nie chciała się połączyć.

Walczyłem dwa dni i poddałem się. Zacząłem "sprzątać" po swoich zmianach i optima zaczęła działać.

Nadal nie wiem co było powodem...

User Avatar
partner
Tadeusz Sasnal
1 pkt
3 pytań
3 odpowiedzi
1 pomysłów
0 komentarzy
1 100%
oceń
 
Tadeusz Sasnal odpowiedział/a
Techniczne
Techniczne pytań: 1497 | odpowiedzi: 5675

Jerzy ZiajaKinga KotelnickaMagdalena GrygaMonika KalaDominik WajdaPiotr PrzybyszOlga WitosMarcin Łach
Comarch ERP Optima
Comarch ERP Optima pytań: 4835 | odpowiedzi: 19305

Optima

Jerzy ZiajaKinga KotelnickaJózef ĆwiąkałaKarolina SypułaMariusz SzczebakMagdalena Grygabartek rosińskiMarzanna Sapkowska
4 mie. temu

Czy ktoś doszedł do rozwiązania tego problemu? 

U mnie sytuacja następująca: 

Końcówki łączą się bez problemu, natomiast komputer na którym stoi SQL ma podany powyżej błąd. 

MSSMS łączy się ładnie zarówno jak wpiszę

  • IP,1433
  • 127.0.0.1\SQLEXPRESS
  • NAZWA_KOMPA,1433

To samo wpisywane w Optime powoduje pokazanie się błędu. 

Ping zwraca ip poprawnie. 

Port ustawiony na stałe, wyjątki zrobiłem w zaporze na ten port. Antywirusa wyłączyłem. Aliasy ustawiałem, ale to chyba bez znaczenia jak się po IP próbuję łączyć.. 

Ta odpowiedź została skomentowana
User Avatar
partner
Daniel Trzeciak
24 pkt
5 pytań
10 odpowiedzi
1 pomysłów
1 komentarzy
4 100%
oceń
 
Daniel Trzeciak odpowiedział/a
Techniczne
Techniczne pytań: 1497 | odpowiedzi: 5675

Jerzy ZiajaKinga KotelnickaMagdalena GrygaMonika KalaDominik WajdaPiotr PrzybyszOlga WitosMarcin Łach
Comarch ERP Optima
Comarch ERP Optima pytań: 4835 | odpowiedzi: 19305

Optima

Jerzy ZiajaKinga KotelnickaJózef ĆwiąkałaKarolina SypułaMariusz SzczebakMagdalena Grygabartek rosińskiMarzanna Sapkowska
4 mie. temu

a kombinacja NAZWA_KOMPA\SQLEXPRESS?

Ta odpowiedź została skomentowana

Masz pytanie?

zadaj pytanie

Masz pomysł?

zgłoś pomysł